Updated System Requirements

In JxBrowser 7.20 we upgraded Chromium to version 94. Apart from being the first one in the Extended Stable channel, in this version the minimum system requirements have changed. Chromium 94 dropped support of some old Linux distributions and macOS versions.

JxBrowser System Requirements have been upgraded accordingly.

macOS

macOS 10.10 is no longer supported. Only macOS 10.11 and higher are supported.

Linux

The minimum supported Linux distributions are the following now:

  • Ubuntu 18.04+
  • Debian 10+
  • Fedora Linux 32+
  • openSUSE 15.2+
  • RedHat Enterprise Linux 7
Go Top